Who came up [with this one](, seriously? > [getInteger](

> public static Integer getInteger(String nm) > Determines the integer value of the system property with the specified name. > The first argument is treated as the name of a system property. System properties are accessible through the `System.getProperty(java.lang.String)` method. The string value of this property is then interpreted as an integer value and an Integer object representing this value is returned. Details of possible numeric formats can be found with the definition of getProperty.

> If there is no property with the specified name, if the specified name is empty or null, or if the property does not have the correct numeric format, then null is returned.

Why the hell would there be a `getInteger()` method on `Integer`, when it is really a wrapper around `System.getProperty()`? Oh, and there's a [Boolean.getBoolean()](

And of course, don't confuse those with [Integer.parseInt()]( and [Boolean.parseBoolean()](

Anybody knows the rationale?